Storyblocks Audio Certificate Error
Incident Report for Storyblocks
Postmortem

The error was caused by an issue with the Storyblocks Audio certificate. The issue was resolved around 10:45 PM ET. We are looking into preventing this issue in the future with various automatic certificate solutions.

Posted Jul 08, 2020 - 11:13 EDT

Resolved
At around 10PM, users on Storyblocks Audio started receiving the error ERR_CERT_DATE_INVALID.
Posted Jul 07, 2020 - 22:00 EDT